Aller au contenu
Top-Metin2.org - Vous êtes à la recherche d'un serveur Metin 2 ? ×
×
×
  • Créer...
  • 0

erreur au lancement du serveur


ShadowMt2

Question

Version des fichiers/ Type d'émulateur : freebsd 10 64 bits

Domaine (Base de données, Client, Core...) : 2012

Votre niveau (Débutant, Intermédiaire, Avancé..) : débutant

 

Description du problème : erreur au lancement

Comment reproduire le problème ? :

Recherches et tests effectués :

 

Screenshot du problème concerné :

 

Bonjour à tous,

 

J'avais des soucis avec Navicat qui ne voulait pas se connecter mais maintenant c'est résolu.

 

Une fois que j'ai réussi à tout refaire sans problème me voilà au lancement du serveur avec la commande sh start.sh et voilà ce que ça me donne :

 

 

Merci d'avance pour votre aide.

 

En postant ma demande d'aide, j'affirme avoir lu et accepté le Règlement de Funky-Emulation.

Modifié par titi1706
Lien vers le commentaire
Partager sur d’autres sites

  • Réponses 21
  • Créé
  • Dernière réponse

Meilleurs contributeurs dans cette question

Meilleurs contributeurs dans cette question

21 réponses à cette question

Messages recommandés

  • 0
  • Retraité

Hello !

 

Tu devrais éviter de mettre un screen avec l'IP de ta machine, c'est pas très safe.

 

Il y a plusieurs problèmes sur ta configuration:

  1. Dans tes fichiers CONFIG de ton serveur metin2, tu te connectes à ta base de données en utilisant son IP alors que ta base de donnés se trouve sur la même machine que ton serveur (localhost). Se connecter à une hôte externe ralentit grandement l’efficacité d'exécution de ton serveur.
  2. Ne jamais mettre l'utilisateur root sur ses services (serveur metin2, site web, etc ..) .. C'est un utilisateur qui possède tous les droits et pour des questions de sécurité, on évite.
  3. Cette erreur indique que tu as mis un mauvais mot de passe à ton utilisateur.

 

Solution:

 

Tu as sûrement suivi ce tutoriel pour mettre en place ta machine: 

 

 

Dans le tutoriel tu remarqueras ce passage:

 

mysql> GRANT ALL PRIVILEGES ON *.* TO 'mt2'@'localhost' IDENTIFIED BY 'mt2!@#' WITH GRANT OPTION;
mysql> flush privileges;
mysql> quit

 

La première ligne créée un nouvel utilisateur mysql accessible SEULEMENT en local. Une personne externe ne peut pas s'y connecter à distance en utilisant cet utilisateur.

Son nom d'utilisateur est mt2 et son mot de passe est mt2!@# (au final tu peux mettre ce que tu veux). On lui met aussi tous les droits avec GRANT ALL PRIVILEGES

La deuxième ligne actualise les droits des utilisateurs mysql, pour que ça se mette à jour.

La troisième ligne quitte la console mysql.

 

Une fois l'utilisateur créé, il faut modifier les fichiers CONFIG de ton serveur pour que ton serveur se connecte à l'utilisateur que tu as créé.

Il te manquera plus qu'à démarrer ton serveur

Lien vers le commentaire
Partager sur d’autres sites

  • 0

Bonsoir et desoler du derangement

je comprends pas pourquoi chez moi ca ne va pas pour la creation de l'utilisateur 

ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that              corresponds to your MySQL server version for the right syntax to use near 

Merci d'avance 

Lien vers le commentaire
Partager sur d’autres sites

  • 0

Je pense avoir reussi enfin regarde si jamais c'est bon 

mysql> GRANT ALL PRIVILEGES ON *.* TO 'root'@'%'IDENTIFIED BY '*****'WITH GRANT OPTION;
Query OK, 0 rows affected (0.00 sec)

mysql> GRANT ALL PRIVILEGES ON *.* TO 'christopher'@'localhost'IDENTIFIED BY'*****'WITH GRANT OPTION;
Query OK, 0 rows affected (0.00 sec)

mysql> flush privileges;
Query OK, 0 rows affected (0.01 sec)
 

Lien vers le commentaire
Partager sur d’autres sites

  • 0

une fois tout fait je tombe la dessus sur putty 


cannot start server while no common sql connected
mysql_real_connect: Unknown MySQL server host '********' (1)
   failed, retrying in 5 secondsPUBLIC_IP: ********* interface em0
HOSTNAME: channel99
mysql_real_connect: Unknown MySQL server host 'christopher' (1)
cannot open direct sql connection to host: christopher user: root db: common
cannot start server while no common sql connected
root@ns3011178:/usr/metin2 # mysql_real_connect: Unknown MySQL server host '********' (1)
   failed, retrying in 5 secondsmysql_real_connect: Unknown MySQL server host '********' (1)
   failed, retrying in 5 secondsmysql_real_connect: Unknown MySQL server host '********' (1)
   failed, retrying in 5 secondsmysql_real_connect: Unknown MySQL server host '********' (1)
   failed, retrying in 5 secondsSuccess PLAYER
mysql_real_connect: Unknown MySQL server host 'christopher' (1)
   failed, retrying in 5 secondsmysql_real_connect: Unknown MySQL server host '********' (1)
   failed, retrying in 5 secondsmysql_real_connect: Unknown MySQL server host '********' (1)
   failed, retrying in 5 seconds

Lien vers le commentaire
Partager sur d’autres sites

  • 0

HOSTNAME: auth
CHANNEL: 1
PORT: 11002
P2P_PORT: 12000
DB_PORT: 15000
DB_ADDR: localhost
TABLE_POSTFIX:
ITEM_ID_RANGE: 000000001 000000002
PASSES_PER_SEC: 25
SAVE_EVENT_SECOND_CYCLE: 180
PING_EVENT_SECOND_CYCLE: 180
AUTH_SERVER: master
PLAYER_SQL: christopher root ****** account
COMMON_SQL: christopher root ****** common
LOG_SQL: christopher root ****** log
LOCALE_SERVICE: france

 

 

HOSTNAME: channel1
CHANNEL: 1
PORT: 13001
P2P_PORT: 14000
DB_PORT: 15000
DB_ADDR: localhost
MAP_ALLOW: 1 3 4 5 21 23 24 25 41 43 44 45 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 84 85 86
TABLE_POSTFIX:
PASSES_PER_SEC: 25
SAVE_EVENT_SECOND_CYCLE: 180
PING_EVENT_SECOND_CYCLE: 180
PLAYER_SQL: christopher root ****** player
COMMON_SQL: christopher root ****** common
LOG_SQL: christopher root ****** log
LOCALE_SERVICE: france
#TEST_SERVER: 1
#NO_PK: 1
MAX_LEVEL: 250
MALL_URL: google.fr
adminpage_ip0: 127.0.0.1
adminpage_ip1: 127.0.0.1
adminpage_ip2: 127.0.0.1
adminpage_ip3: 127.0.0.1
admin_page_password: dmpe/DKH*éàlJD
VIEW_RANGE: 20000
 pareil pour tout les autres

Modifié par Kameyu
Retrait des mots de passes
Lien vers le commentaire
Partager sur d’autres sites

  • 0
  • Retraité

Tu as encore une fois laissé le mot de passe de ton utilisateur root ...
 

Je t'invite à relire la fin de mon premier message du topic.

Tes CONFIGS doivent se connecter avec ton utilisateur en localhost.

Tes lignes *_SQL sont sous cette forme:   host user password table

 

L'host ici serait localhost

Lien vers le commentaire
Partager sur d’autres sites

  • 0

Bonjour a tous

Alors cette nuit j'ai decidé de tout reprendre a zero pour ne pas faire de betises.

j'ai tout delete de mon pc et tout re'telecharger ainsi que re installer mon freebsd sur le dedié.

Et la surprise Putty me demande le Login : root 

et le mot de passe il me sort incorrect et pourtant j'en suis bien sur de taper le bon 

Je ne sais pas quoi faire

Lien vers le commentaire
Partager sur d’autres sites

Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.


  • brilliantdiscord_widget
  • Flux d'Activité

    1. 0

      Renouveau

    2. 0

      OldEraMT2 recrute – la bêta ouverte est en cours

    3. 0

      OldEraMT2 | Classique 2009 Oldschool | Niveau 99 | 7 langues | Sans pay2win | Bêta ouverte

    4. 6

      problème de connexion à mon serveur local (je suis débutant dans ce genre d'entreprise )

    5. 2

      problème de lancement serveur

    6. 9
    7. 0

      [PVM/PVP] ATLAX2 - EASY PLAY

Information importante

Conditions d’utilisation / Politique de confidentialité / Règles / Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.